We are continuing to verify the maintenance items.
Posted Jul 31, 2024 - 02:12 IDT
Verifying
Verification is currently underway for the maintenance items.
Posted Jul 31, 2024 - 02:12 IDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jul 31, 2024 - 00:47 IDT
Update
Dear Partner, We are sending this message to inform you that we are rescheduling the maintenance that was initially scheduled for August 11, 2024 to today, Tuesday, July 30, 2024, from 5:00 pm until 7:00 pm ET. This may result in brief service interruptions, including but not limited to: Partner APIs, Payment processing, and Pay with Payoneer. We advise that you do not schedule or make payments during this maintenance window.
We will let you know once the maintenance is completed. Please visit Payoneer Status Page for the latest operational status of our system.
If you have any questions, you can reach the Client Services team via Help -> Contact us in the admin console or call our US toll-free number at +1-888-502-8333
US Land Line: +1-800-251-2521
We apologize for any inconvenience, and thank you for your understanding and cooperation, The Payoneer Team
Posted Jul 31, 2024 - 00:16 IDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 31, 2024 - 00:00 IDT
Scheduled
Dear Partner, We’re sending this message to inform you that we have a maintenance window scheduled on Sunday, August 11 from 00:00am until 03:00am ET that could result in brief service interruptions, including but not limited to: Partner APIs, Payment processing, and Pay with Payoneer. We advise that you do not schedule or make payments during this maintenance window. We will let you know once the maintenance is completed. Please visit https://status.payoneer.com for the latest operational status of our system. If you have any questions, you can reach the Client Services team via Help > Contact us in the admin console or call our US toll-free number at +1-888-502-8333.US Land Line +1-800-251-2521 We apologize for any inconvenience, and thank you for your understanding and cooperation, The Payoneer Team
Posted Jul 29, 2024 - 19:25 IDT
This scheduled maintenance affected: API, Mass payout account, Payments, Registration, and Payoneer account.