A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2024 - 20:44 IST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 19:30 IST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 18:57 IST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 18:29 IST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 18:02 IST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 17:32 IST
Investigating
Dear Client,
Please be informed that we are currently experiencing a technical issue with our payments capabilities. You may experience delays in Payments processing.
We are investigating the matter with the highest level of urgency. Please refer to our status page for updates and more information on the affected components. http://status.payoneer.com/.
Please feel free to reach out to our Client Services team at the phone numbers below.