A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2024 - 11:31 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2024 - 11:23 IST
Investigating
Dear Client,
Please be informed that we are currently experiencing a technical issue.
We are investigating the matter with the highest level of urgency. Please refer to our status page for updates and more information on the affected components. http://status.payoneer.com/.
Please feel free to reach out to our Client Services team at the phone numbers below.
Regards,
The Client Services Team
US Toll Free: +1.888.502.8333 ext. 444
US Land Line: +1.646.328.0950 ext. 444
UK: +44.203.318.9054 ext. 444
Germany: +49.89.7210.1064.746 ext. 444
Israel: +972.732633578 ext. 444
Posted Nov 13, 2024 - 11:02 IST
This incident affected: API, Mass payout account, Payments, Registration, and Payoneer account.