Dear Partner, We wish to inform you that the scheduled maintenance previously planned for July 19 has been postponed. The maintenance has been rescheduled to August 17 from 00:30 AM until 06:30 AM EST. We will continue to keep you informed and share any relevant information as needed.
Please visit https://status.payoneer.com for the latest operational status of our system. If you have any questions, you can reach the Client Services team via Help > Contact us in the admin console or call our US toll-free number at +1-888-502-8333.US Land Line +1-800-251-2521
We apologize for any inconvenience, and thank you for your understanding and cooperation, The Payoneer Team.
Posted Jul 01, 2025 - 11:06 IDT
Scheduled
Dear Partner, We’re sending this message to inform you that we have a maintenance window scheduled on Saturday, July 19 from 14:00 pm until 20:00 pm EST that could result in brief service interruptions, including but not limited to: Partner APIs, Payment processing, and Pay with Payoneer. We will let you know once the maintenance is completed. Please visit https://status.payoneer.com for the latest operational status of our system. If you have any questions, you can reach the Client Services team via Help > Contact us in the admin console or call our US toll-free number at +1-888-502-8333.US Land Line +1-800-251-2521 We apologize for any inconvenience, and thank you for your understanding and cooperation, The Payoneer Team.
Posted Jun 22, 2025 - 16:05 IDT
This scheduled maintenance affects: API, Mass payout account, Payments, Registration, and Payoneer account.